use strict;
my $str = '32132132132 32132132132 321321321323 32132132132132';
my $regex = qr/[0-9]+(?= |$)/p;
my $subst = '\'$0\',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";