using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"abc.*clean.*|clean.*abc.*";
string input = @"abc_clean.csv
abc_other_clean.csv
abc_other_raw.csv
abc_raw.csv
abc_something_clean.csv
abc_something_raw.csv
def_clean.csv
def_other_clean.csv
def_something_clean.csv
clean_abc_file.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}