$re = '/abc.*clean.*|clean.*abc.*/m';
$str = 'abc_clean.csv
abc_other_clean.csv
abc_other_raw.csv
abc_raw.csv
abc_something_clean.csv
abc_something_raw.csv
def_clean.csv
def_other_clean.csv
def_something_clean.csv
clean_abc_file.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);