re = /abc.*clean.*|clean.*abc.*/m
str = 'abc_clean.csv
abc_other_clean.csv
abc_other_raw.csv
abc_raw.csv
abc_something_clean.csv
abc_something_raw.csv
def_clean.csv
def_other_clean.csv
def_something_clean.csv
clean_abc_file.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end