use strict;
my $str = 'abc_clean.csv
abc_other_clean.csv
abc_other_raw.csv
abc_raw.csv
abc_something_clean.csv
abc_something_raw.csv
def_clean.csv
def_other_clean.csv
def_something_clean.csv
clean_abc_file.csv';
my $regex = qr/abc.*clean.*|clean.*abc.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}