package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)abc.*clean.*|clean.*abc.*`)
var str = `abc_clean.csv
abc_other_clean.csv
abc_other_raw.csv
abc_raw.csv
abc_something_clean.csv
abc_something_raw.csv
def_clean.csv
def_other_clean.csv
def_something_clean.csv
clean_abc_file.csv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}