#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[3-8]{1}\'([0-9]{1}|0[0-9]{1}|1[0-1]{1})(\"|\s*((1\/4|1\/2|3\/4))\")$"
Local $sString = "2'11"" & @CRLF & _
"3'00"" & @CRLF & _
"4'11"" & @CRLF & _
"5'6"" & @CRLF & _
"5'11"" & @CRLF & _
"6'0"" & @CRLF & _
"7' 1"" & @CRLF & _
"5'2 1/2"" & @CRLF & _
"5'0"" & @CRLF & _
"5'8 3/4"" & @CRLF & _
"7'0"" & @CRLF & _
"7'20"" & @CRLF & _
"6'1"" & @CRLF & _
"6'12"" & @CRLF & _
"6'1 1/3"" & @CRLF & _
"6'1 4/1"" & @CRLF & _
"6'1 1/4"" & @CRLF & _
"6'1 2/4"" & @CRLF & _
"6'1 3/4"" & @CRLF & _
"6'11 3/4"" & @CRLF & _
"7'1"" & @CRLF & _
"7'2"" & @CRLF & _
"7'9"" & @CRLF & _
"7'10"" & @CRLF & _
"7'12""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")