import Foundation
let pattern = #"^[3-8]{1}\'([0-9]{1}|0[0-9]{1}|1[0-1]{1})(\"|\s*((1\/4|1\/2|3\/4))\")$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2'11"
3'00"
4'11"
5'6"
5'11"
6'0"
7' 1"
5'2 1/2"
5'0"
5'8 3/4"
7'0"
7'20"
6'1"
6'12"
6'1 1/3"
6'1 4/1"
6'1 1/4"
6'1 2/4"
6'1 3/4"
6'11 3/4"
7'1"
7'2"
7'9"
7'10"
7'12"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)