# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[3-8]{1}\'([0-9]{1}|0[0-9]{1}|1[0-1]{1})(\"|\s*((1\/4|1\/2|3\/4))\")$"
test_str = ("2'11\"\n"
"3'00\"\n"
"4'11\"\n"
"5'6\"\n"
"5'11\"\n"
"6'0\"\n"
"7' 1\"\n"
"5'2 1/2\"\n"
"5'0\"\n"
"5'8 3/4\"\n"
"7'0\"\n"
"7'20\"\n"
"6'1\"\n"
"6'12\"\n"
"6'1 1/3\"\n"
"6'1 4/1\"\n"
"6'1 1/4\"\n"
"6'1 2/4\"\n"
"6'1 3/4\"\n"
"6'11 3/4\"\n"
"7'1\"\n"
"7'2\"\n"
"7'9\"\n"
"7'10\"\n"
"7'12\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.