import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[3-8]{1}\\'([0-9]{1}|0[0-9]{1}|1[0-1]{1})(\\\"|\\s*((1\\/4|1\\/2|3\\/4))\\\")$";
final String string = "2'11\"\n"
+ "3'00\"\n"
+ "4'11\"\n"
+ "5'6\"\n"
+ "5'11\"\n"
+ "6'0\"\n"
+ "7' 1\"\n"
+ "5'2 1/2\"\n"
+ "5'0\"\n"
+ "5'8 3/4\"\n"
+ "7'0\"\n"
+ "7'20\"\n"
+ "6'1\"\n"
+ "6'12\"\n"
+ "6'1 1/3\"\n"
+ "6'1 4/1\"\n"
+ "6'1 1/4\"\n"
+ "6'1 2/4\"\n"
+ "6'1 3/4\"\n"
+ "6'11 3/4\"\n"
+ "7'1\"\n"
+ "7'2\"\n"
+ "7'9\"\n"
+ "7'10\"\n"
+ "7'12\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}