#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(£|\$)[0-9]+.[0-9]+"
Local $sString = "CHOC. ORANGE x £1.00" & @CRLF & _
"" & @CRLF & _
"£10.00" & @CRLF & _
"£155555555555555555.00" & @CRLF & _
"20" & @CRLF & _
"£144444444444444444.004444444444444444444444" & @CRLF & _
"$50.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")