package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(£|\$)[0-9]+.[0-9]+`)
var str = `CHOC. ORANGE x £1.00
£10.00
£155555555555555555.00
20
£144444444444444444.004444444444444444444444
$50.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}