$re = '/(£|\$)[0-9]+.[0-9]+/';
$str = 'CHOC. ORANGE x £1.00
£10.00
£155555555555555555.00
20
£144444444444444444.004444444444444444444444
$50.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);