re = /(£|\$)[0-9]+.[0-9]+/
str = 'CHOC. ORANGE x £1.00
£10.00
£155555555555555555.00
20
£144444444444444444.004444444444444444444444
$50.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end