import Foundation
let pattern = #"(£|\$)[0-9]+.[0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
CHOC. ORANGE x £1.00
£10.00
£155555555555555555.00
20
£144444444444444444.004444444444444444444444
$50.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)