# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Starting(?=[\s\S]+?(?:Complete|(FAIL)))(?(1)[\s\S]+?FAIL|garbage to prevent matching)//gm;t' <<< "Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL
"