import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Starting(?=[\\s\\S]+?(?:Complete|(FAIL)))(?(1)[\\s\\S]+?FAIL|garbage to prevent matching)";
final String string = "Starting - blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah Complete\n"
+ "Starting - blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah FAIL\n"
+ "Starting - blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah Complete\n"
+ "Starting - blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah\n"
+ "blah blah blah FAIL\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}