const regex = /Starting(?=[\s\S]+?(?:Complete|(FAIL)))(?(1)[\s\S]+?FAIL|garbage to prevent matching)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Starting(?=[\\s\\S]+?(?:Complete|(FAIL)))(?(1)[\\s\\S]+?FAIL|garbage to prevent matching)', 'gm')
const str = `Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);