$re = '/Starting(?=[\s\S]+?(?:Complete|(FAIL)))(?(1)[\s\S]+?FAIL|garbage to prevent matching)/m';
$str = 'Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah Complete
Starting - blah blah blah
blah blah blah
blah blah blah
blah blah blah
blah blah blah FAIL
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;