#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Starting(?=[\s\S]+?(?:Complete|(FAIL)))(?(1)[\s\S]+?FAIL|garbage to prevent matching)"
Local $sString = "Starting - blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah Complete" & @CRLF & _
"Starting - blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah FAIL" & @CRLF & _
"Starting - blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah Complete" & @CRLF & _
"Starting - blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"blah blah blah FAIL" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)