#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^\/].*[0-9])(?=[^\/].*[A-Z])([A-Z0-9\/]+[^\/])$"
Local $sString = "123ABC" & @CRLF & _
"123456" & @CRLF & _
"ABCDE" & @CRLF & _
"ABC1" & @CRLF & _
"AB7CDE" & @CRLF & _
"AB3CD8E/H" & @CRLF & _
"/AB7CDE" & @CRLF & _
"AC6DE8/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")