import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^\\/].*[0-9])(?=[^\\/].*[A-Z])([A-Z0-9\\/]+[^\\/])$";
final String string = "123ABC\n"
+ "123456\n"
+ "ABCDE\n"
+ "ABC1\n"
+ "AB7CDE\n"
+ "AB3CD8E/H\n"
+ "/AB7CDE\n"
+ "AC6DE8/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}