using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^\/].*[0-9])(?=[^\/].*[A-Z])([A-Z0-9\/]+[^\/])$";
string input = @"123ABC
123456
ABCDE
ABC1
AB7CDE
AB3CD8E/H
/AB7CDE
AC6DE8/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}