import re
regex = re.compile(r"^(?=[^\/].*[0-9])(?=[^\/].*[A-Z])([A-Z0-9\/]+[^\/])$", flags=re.MULTILINE)
test_str = ("123ABC\n"
"123456\n"
"ABCDE\n"
"ABC1\n"
"AB7CDE\n"
"AB3CD8E/H\n"
"/AB7CDE\n"
"AC6DE8/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")