$re = '/^(?=[^\/].*[0-9])(?=[^\/].*[A-Z])([A-Z0-9\/]+[^\/])$/m';
$str = '123ABC
123456
ABCDE
ABC1
AB7CDE
AB3CD8E/H
/AB7CDE
AC6DE8/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);