#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=\/\*).*(?=\*\/)"
Local $sString = "/*" & @CRLF & _
"//This is the test string" & @CRLF & _
"with a big" & @CRLF & _
"" & @CRLF & _
"comment" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"sadasdasdsa" & @CRLF & _
"" & @CRLF & _
"asdasdasdasdas"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")