using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\/\*).*(?=\*\/)";
string input = @"/*
//This is the test string
with a big
comment
*/
sadasdasdsa
asdasdasdasdas";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}