$re = '/(?<=\/\*).*(?=\*\/)/s';
$str = '/*
//This is the test string
with a big
comment
*/
sadasdasdsa
asdasdasdasdas';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);