re = /(?<=\/\*).*(?=\*\/)/
str = '/*
//This is the test string
with a big
comment
*/
sadasdasdsa
asdasdasdasdas'
# Print the match result
str.match(re) do |match|
puts match.to_s
end