import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\\)[^\\\\]+$";
final String string = "C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png\n"
+ "\\\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png\n"
+ "\\\\my-local-server\\path\\to\\this_file may_contain-any&character.pdf\n"
+ "\\\\my-local-.net\\server\\path\\to\\this_file may_contain-any&character.pdf\n"
+ "\\\\my-local-.netd\\server\\path\\to\\this_file may_contain-any&character.pdf\n"
+ "\\\\my-local-.netd\\server\\path\\to\\this_file may_contain-any&character\n"
+ "\\\\my-local-.netd\\server\\path\\to\\.this_file may_contain-any&character\n"
+ ".\\hallo\n"
+ ".\\.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}