use strict;
my $str = 'C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
\\\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
\\\\my-local-server\\path\\to\\this_file may_contain-any&character.pdf
\\\\my-local-.net\\server\\path\\to\\this_file may_contain-any&character.pdf
\\\\my-local-.netd\\server\\path\\to\\this_file may_contain-any&character.pdf
\\\\my-local-.netd\\server\\path\\to\\this_file may_contain-any&character
\\\\my-local-.netd\\server\\path\\to\\.this_file may_contain-any&character
.\\hallo
.\\.txt';
my $regex = qr/(?<=\\)[^\\]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}