import re
regex = re.compile(r"(?<=\\)[^\\]+$", flags=re.MULTILINE)
test_str = ("C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png\n"
"\\\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png\n"
"\\\\my-local-server\\path\\to\\this_file may_contain-any&character.pdf\n"
"\\\\my-local-.net\\server\\path\\to\\this_file may_contain-any&character.pdf\n"
"\\\\my-local-.netd\\server\\path\\to\\this_file may_contain-any&character.pdf\n"
"\\\\my-local-.netd\\server\\path\\to\\this_file may_contain-any&character\n"
"\\\\my-local-.netd\\server\\path\\to\\.this_file may_contain-any&character\n"
".\\hallo\n"
".\\.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")