#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=ABC DEF G)[\s\S]*(?=ABC DEF G)"
Local $sString = "lskjldkfds" & @CRLF & _
"fdsjfkldsjflds sdbfkjdsf sdfhdsfmnsdfkjdsf dsfnkjsbsd fsdf" & @CRLF & _
"sdfkjhsdkfns foisdfnsdf sdfs" & @CRLF & _
"dfskjflksdjfl sdflksdfds fdskfmds f sfmdlkfmlsdf sdbfkjdsf" & @CRLF & _
"sdjfksdkfjklj ABC DEF G lisjikdflksdmf\sdf sdoifj sdf\sdfhsdf\]sdfsd\fdsjfkldsjfldsdsfsdds" & @CRLF & _
"dsflkjdslkfds" & @CRLF & _
"fdsjfkldsjfldsdsfsddssdfsd" & @CRLF & _
"fldsfdlfds" & @CRLF & _
"fsdffsd" & @CRLF & _
"gfdfg" & @CRLF & _
"fdhdsdf'dsflkjdslkfdsfgspdfkl;sd ABC DEF G sidjflksdfbjhsbdf" & @CRLF & _
"sdfhsdkjjfksdnlfkjsdlf dsflkjdslkfdsfdsfjlsdfds" & @CRLF & _
"" & @CRLF & _
"sdflkjsdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")