import Foundation
let pattern = #"(?<=ABC DEF G)[\s\S]*(?=ABC DEF G)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
lskjldkfds
fdsjfkldsjflds sdbfkjdsf sdfhdsfmnsdfkjdsf dsfnkjsbsd fsdf
sdfkjhsdkfns foisdfnsdf sdfs
dfskjflksdjfl sdflksdfds fdskfmds f sfmdlkfmlsdf sdbfkjdsf
sdjfksdkfjklj ABC DEF G lisjikdflksdmf\sdf sdoifj sdf\sdfhsdf\]sdfsd\fdsjfkldsjfldsdsfsdds
dsflkjdslkfds
fdsjfkldsjfldsdsfsddssdfsd
fldsfdlfds
fsdffsd
gfdfg
fdhdsdf'dsflkjdslkfdsfgspdfkl;sd ABC DEF G sidjflksdfbjhsbdf
sdfhsdkjjfksdnlfkjsdlf dsflkjdslkfdsfdsfjlsdfds
sdflkjsdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)