$re = '/(?<=ABC DEF G)[\s\S]*(?=ABC DEF G)/';
$str = 'lskjldkfds
fdsjfkldsjflds sdbfkjdsf sdfhdsfmnsdfkjdsf dsfnkjsbsd fsdf
sdfkjhsdkfns foisdfnsdf sdfs
dfskjflksdjfl sdflksdfds fdskfmds f sfmdlkfmlsdf sdbfkjdsf
sdjfksdkfjklj ABC DEF G lisjikdflksdmf\\sdf sdoifj sdf\\sdfhsdf\\]sdfsd\\fdsjfkldsjfldsdsfsdds
dsflkjdslkfds
fdsjfkldsjfldsdsfsddssdfsd
fldsfdlfds
fsdffsd
gfdfg
fdhdsdf\'dsflkjdslkfdsfgspdfkl;sd ABC DEF G sidjflksdfbjhsbdf
sdfhsdkjjfksdnlfkjsdlf dsflkjdslkfdsfdsfjlsdfds
sdflkjsdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);