use strict;
my $str = 'lskjldkfds
fdsjfkldsjflds sdbfkjdsf sdfhdsfmnsdfkjdsf dsfnkjsbsd fsdf
sdfkjhsdkfns foisdfnsdf sdfs
dfskjflksdjfl sdflksdfds fdskfmds f sfmdlkfmlsdf sdbfkjdsf
sdjfksdkfjklj ABC DEF G lisjikdflksdmf\\sdf sdoifj sdf\\sdfhsdf\\]sdfsd\\fdsjfkldsjfldsdsfsdds
dsflkjdslkfds
fdsjfkldsjfldsdsfsddssdfsd
fldsfdlfds
fsdffsd
gfdfg
fdhdsdf\'dsflkjdslkfdsfgspdfkl;sd ABC DEF G sidjflksdfbjhsbdf
sdfhsdkjjfksdnlfkjsdlf dsflkjdslkfdsfdsfjlsdfds
sdflkjsdf';
my $regex = qr/(?<=ABC DEF G)[\s\S]*(?=ABC DEF G)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}