const regex = /(?<=ABC DEF G)[\s\S]*(?=ABC DEF G)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=ABC DEF G)[\\s\\S]*(?=ABC DEF G)', 'g')
const str = `lskjldkfds
fdsjfkldsjflds sdbfkjdsf sdfhdsfmnsdfkjdsf dsfnkjsbsd fsdf
sdfkjhsdkfns foisdfnsdf sdfs
dfskjflksdjfl sdflksdfds fdskfmds f sfmdlkfmlsdf sdbfkjdsf
sdjfksdkfjklj ABC DEF G lisjikdflksdmf\\sdf sdoifj sdf\\sdfhsdf\\]sdfsd\\fdsjfkldsjfldsdsfsdds
dsflkjdslkfds
fdsjfkldsjfldsdsfsddssdfsd
fldsfdlfds
fsdffsd
gfdfg
fdhdsdf'dsflkjdslkfdsfgspdfkl;sd ABC DEF G sidjflksdfbjhsbdf
sdfhsdkjjfksdnlfkjsdlf dsflkjdslkfdsfdsfjlsdfds
sdflkjsdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}