using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]+\.[0-9]+\.[0-9]+(-([a-zA-Z]+)?[0-9]*)?$";
string input = @"1.0.0
1.0.0-0
1.0.0-42
1.0.0-alpha
1.0.0-alpha1
1.0.0-alpha42
1.0.0-anything
1.0.0-anything1
1.0.0-anything42";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}