// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]+\.[0-9]+\.[0-9]+(-([a-zA-Z]+)?[0-9]*)?$").unwrap();
let string = "1.0.0
1.0.0-0
1.0.0-42
1.0.0-alpha
1.0.0-alpha1
1.0.0-alpha42
1.0.0-anything
1.0.0-anything1
1.0.0-anything42";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}