import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]+\\.[0-9]+\\.[0-9]+(-([a-zA-Z]+)?[0-9]*)?$";
final String string = "1.0.0\n"
+ "1.0.0-0\n"
+ "1.0.0-42\n"
+ "1.0.0-alpha\n"
+ "1.0.0-alpha1\n"
+ "1.0.0-alpha42\n"
+ "1.0.0-anything\n"
+ "1.0.0-anything1\n"
+ "1.0.0-anything42";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}