$re = '/^[0-9]+\.[0-9]+\.[0-9]+(-([a-zA-Z]+)?[0-9]*)?$/m';
$str = '1.0.0
1.0.0-0
1.0.0-42
1.0.0-alpha
1.0.0-alpha1
1.0.0-alpha42
1.0.0-anything
1.0.0-anything1
1.0.0-anything42';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);