using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$scope\.[a-zA-Z]*\s\=\[";
string input = @"$scope.proveedores =[{asdk oiaduas asoid a}]
$scope.cleintes =[{asdk oiaduas asoid a}]
$scope.ubicaciones =[{asdk oiaduas asoid a}]
$scope.loremipsum =[{asdk oiaduas asoid a}]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}