// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"\$scope\.[a-zA-Z]*\s\=\[").unwrap();
  let string = "$scope.proveedores =[{asdk oiaduas asoid a}]
$scope.cleintes =[{asdk oiaduas asoid a}]
$scope.ubicaciones =[{asdk oiaduas asoid a}]
$scope.loremipsum =[{asdk oiaduas asoid a}]";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}