using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]|D[ei][A-Z]|Mc[A-Z]|Mac[A-Z]|O[`'])[a-z]+";
string input = @"Standard
StAndard
DeDonno
Dabc
O'reilly
GaGBec
Diflora
DiFloria
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}