// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z]|D[ei][A-Z]|Mc[A-Z]|Mac[A-Z]|O[`'])[a-z]+").unwrap();
let string = "Standard
StAndard
DeDonno
Dabc
O'reilly
GaGBec
Diflora
DiFloria
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}