$re = '/([A-Z]|D[ei][A-Z]|Mc[A-Z]|Mac[A-Z]|O[`\'])[a-z]+/';
$str = 'Standard
StAndard
DeDonno
Dabc
O\'reilly
GaGBec
Diflora
DiFloria
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);