# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^#\| label: .+)_/-/gm;t' <<< "#| label: this_this_is_a_test
my_function_name <- function(x)"