const regex = new RegExp('(?<=^#\\| label: .+)_', 'gm')
const str = `#| label: this_this_is_a_test
my_function_name <- function(x)`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);