use strict;
my $str = '#| label: this_this_is_a_test
my_function_name <- function(x)';
my $regex = qr/(?<=^#\| label: .+)_/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";