re = /(?<=^#\| label: .+)_/m
str = '#| label: this_this_is_a_test
my_function_name <- function(x)'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result